Dani Sánchez, Gestionatuweb.net

Desarrollador web freelance

Tu alojamiento web no es compatible con la rotación de imágenes. [Solución]

Puede que en alguna ocasión trabajando en una instalación de WordPress te encuentres con el siguiente error: «Tu alojamiento web no es compatible con la rotación de imágenes.

Por lo que no podrás editar imágenes desde WordPress, como por ejemplo, escalarlas, cambiar la relación de aspecto, etc. También puede ser un problema si estás trabajando con algún builder como Elementor o Divi, ya que no podrás manipular correctamente las imágenes.

El problema es la falta de algunos complementos de PHP que necesitan ser instalados en el servidor, en concreto los paquetes:

  • php-gd
  • php-imagick

Si estamos trabajando en un servidor online, debemos pedir a nuestro proveedor que instale estos complementos (sería muy raro que no estuviesen instalados, pero cualquiera sabe…).

En el caso de que estés usando una instalación LAMP en local, instala los paquetes desde tu repositorio:

Ubuntu/Debian:

sudo apt install php-gd php-imagick

Arch/Manjaro:

sudo pacman -S php-gd php-imagick

Fedora:

sudo dnf install php-gd php-imagick

Además hay que habilitar la extensión de php-gd desde el archivo de configuración php.ini

Ubuntu/Debian:

sudo nano /etc/php/X.X/apache2/php.ini

Arch/Manjaro:

sudo nano /etc/php/php.ini

Fedora:

sudo nano /etc/php.ini

Y descomentar la línea:

extension=gd

Reiniciar el servidor y listo.

Deja el primer comentario

Recomiendo para hosting

Raiola Networks